Requisitos do sistema

Esta página descreve as configurações de software e hardware necessárias para executar um programa baseado no DotNetBrowser.

Requisitos de software

.NET

  • .NET Framework 4.5 - 4.8.1 (apenas Windows)
  • .NET Core 2.2 (apenas funcionalidade principal)
  • .NET Core 3.0, 3.1
  • .NET 5 - 8

Windows

O DotNetBrowser suporta x86, x64 e ARM64:

  • Windows 11
  • Windows 10
  • Windows Server 2022
  • Windows Server 2019
  • Windows Server 2016

O Windows 7/8/8.1 e as versões correspondentes do Windows Server já não são suportadas.

Linux

O DotNetBrowser suporta as seguintes distribuições Linux (x64 e ARM64):

  • Ubuntu 18.04+
  • Debian 10+
  • Fedora Linux 33+
  • openSUSE 15.2+
  • RedHat Enterprise Linux 7

O Chromium não funciona no ambiente headless. Para usar o DotNetBrowser em ambientes headless, incluindo contêineres Docker baseados em Linux e WSL, é necessário [iniciar o servidor X] (/pt/docs/guides/headless-linux.html).

macOS

O DotNetBrowser suporta o macOS 10.15 Catalina e superior (x64 e ARM64).

Requisitos de hardware

Monitores HiDPI

O DotNetBrowser reconhece o fator de escala do dispositivo que é utilizado nos ambientes com telas HiDPI e processa o conteúdo HTML de acordo com esse fator de escala.

Os controles WPF e WinForms BrowserView são compatíveis com diferentes modos de reconhecimento de DPI. O DotNetBrowser obtém as definições de reconhecimento de DPI da configuração da aplicação onde é utilizado e configura os processos do Chromium para utilizarem o mesmo modo de reconhecimento de DPI.

O DotNetBrowser suporta DPI elevado apenas se a sua aplicação de ambiente de trabalho .NET o suportar.

Estes artigos do MSDN descrevem como criar aplicações de ambiente de trabalho .NET com reconhecimento de DPI:

Android/iOS

O DotNetBrowser não é compatível com dispositivos móveis com iOS e Android.

Outros ambientes

Você pode tentar executar o DotNetBrowser em outras plataformas ou versões não listadas aqui, mas não garantimos que todas as funcionalidades do DotNetBrowser funcionem corretamente.

O DotNetBrowser não pode ser usado em ambientes que impedem que as APIs User32/GDI32 sejam chamadas, como o Azure App Services ou o Azure Functions. Com estas limitações, não é possível lançar o engine Chromium.

Go Top